#openstack-keystone: keystone

Meeting started by d34dh0r53 at 15:04:05 UTC (full logs).

Meeting summary

    1. https://openinfra.dev/legal/code-of-conduct (d34dh0r53, 15:04:32)

  1. roll call (d34dh0r53, 15:04:40)
  2. review past meeting work items (d34dh0r53, 15:06:29)
    1. https://meetings.opendev.org/meetings/keystone/2024/keystone.2024-11-20-15.12.html (d34dh0r53, 15:06:47)

  3. liaison updates (d34dh0r53, 15:07:38)
  4. specification OAuth 2.0 (hiromu) (d34dh0r53, 15:09:13)
    1. https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext (d34dh0r53, 15:09:14)
    2. https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability (d34dh0r53, 15:09:15)
    3. https://review.opendev.org/c/openstack/keystone-specs/+/861554 (merged) (d34dh0r53, 15:09:18)
    4. https://review.opendev.org/q/topic:bp%252Fsupport-oauth2-mtls (d34dh0r53, 15:09:25)
    5. https://review.opendev.org/c/openstack/keystone/+/838108 (merged) (d34dh0r53, 15:09:33)
    6. https://review.opendev.org/c/openstack/keystoneauth/+/838104 (merged) (d34dh0r53, 15:09:38)

  5. specification Secure RBAC (dmendiza[m]) (d34dh0r53, 15:09:54)
    1. https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_ (d34dh0r53, 15:09:58)

  6. specification OpenAPI support (gtema) (d34dh0r53, 15:13:02)
    1. https://review.opendev.org/q/topic:%22openapi%22+project:openstack/keystone (d34dh0r53, 15:13:04)

  7. specification domain manager (mhen) (d34dh0r53, 15:15:23)
  8. specification Include bad password details in audit messages (stanislav-z) (d34dh0r53, 15:18:34)
    1. https://review.opendev.org/c/openstack/keystone-specs/+/915482 (d34dh0r53, 15:18:37)
    2. https://review.opendev.org/c/openstack/keystone/+/932423 (d34dh0r53, 15:18:40)
    3. ACTION: reviewathon look at the Bad Password spec https://review.opendev.org/c/openstack/keystone-specs/+/915482 (d34dh0r53, 15:22:04)

  9. open discussion (d34dh0r53, 15:22:17)
    1. https://review.opendev.org/c/openstack/keystone/+/936721 (d34dh0r53, 15:22:22)
    2. https://review.opendev.org/q/topic:%22pagination%22+project:openstack/keystone (d34dh0r53, 15:25:45)
    3. https://review.opendev.org/c/openstack/keystone/+/933598 must be merged before next work can be started (d34dh0r53, 15:25:49)

  10. bug review (d34dh0r53, 15:29:18)
    1. https://bugs.launchpad.net/keystone/?orderby=-id&start=0 (d34dh0r53, 15:29:22)
    2. https://bugs.launchpad.net/keystone/+bug/2089051 (d34dh0r53, 15:29:43)
    3. https://bugs.launchpad.net/keystone/+bug/2089403 (d34dh0r53, 15:31:23)
    4. https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0 (d34dh0r53, 15:37:41)
    5. https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0 (d34dh0r53, 15:38:20)
    6. https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0 (d34dh0r53, 15:38:33)
    7. https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0 (d34dh0r53, 15:38:47)
    8. https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0 (d34dh0r53, 15:38:59)

  11. conclusion (d34dh0r53, 15:39:09)


Meeting ended at 15:39:39 UTC (full logs).

Action items

  1. reviewathon look at the Bad Password spec https://review.opendev.org/c/openstack/keystone-specs/+/915482


People present (lines said)

  1. d34dh0r53 (95)
  2. gtema (26)
  3. opendevmeet (3)
  4. dmendiza[m] (3)
  5. cardoe (1)


Generated by MeetBot 0.1.4.