#openstack-keystone: keystone

Meeting started by gtema at 15:05:41 UTC (full logs).

Meeting summary

    1. https://openinfra.dev/legal/code-of-conduct (gtema, 15:06:04)

  1. roll call (gtema, 15:06:19)
  2. review past meeting work items (gtema, 15:08:13)
    1. https://meetings.opendev.org/meetings/keystone/2025/keystone.2025-05-28-15.02.html (gtema, 15:08:39)

  3. liaison updates (gtema, 15:09:02)
  4. specification OAuth 2.0 (hiromu) (d34dh0r53, 15:12:55)
    1. https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext (d34dh0r53, 15:13:09)
    2. https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability (d34dh0r53, 15:13:14)
    3. https://review.opendev.org/c/openstack/keystone-specs/+/861554 (merged) (d34dh0r53, 15:13:33)
    4. https://review.opendev.org/q/topic:bp%252Fsupport-oauth2-mtls (merged) (d34dh0r53, 15:13:59)
    5. https://review.opendev.org/c/openstack/keystone/+/838108 (merged) (d34dh0r53, 15:14:12)
    6. https://review.opendev.org/c/openstack/keystoneauth/+/838104 (merged) (d34dh0r53, 15:14:21)

  5. specification Secure RBAC (dmendiza[m]) (d34dh0r53, 15:14:42)
    1. https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_ (d34dh0r53, 15:14:46)
    2. ACTION: dmendiza update S-RBAC topic in meeting etherpad (d34dh0r53, 15:16:49)

  6. specification OpenAPI support (gtema) (d34dh0r53, 15:17:31)
    1. https://review.opendev.org/q/topic:%22openapi%22+project:openstack/keystone (d34dh0r53, 15:17:36)
    2. https://review.opendev.org/q/topic:%22openapi%22+project:openstack/keystone+is:open (gtema, 15:18:13)

  7. open discussion (d34dh0r53, 15:20:29)
    1. https://summit2025.openinfra.org/cfp/ (d34dh0r53, 15:22:20)

  8. bug review (d34dh0r53, 15:30:44)
    1. https://bugs.launchpad.net/keystone/?orderby=-id&start=0 (d34dh0r53, 15:30:55)
    2. https://bugs.launchpad.net/keystone/+bug/2112477 (d34dh0r53, 15:31:04)
    3. https://bugs.launchpad.net/keystone/+bug/2112112 (d34dh0r53, 15:38:05)
    4. https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0 (d34dh0r53, 15:45:45)
    5. https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0 (d34dh0r53, 15:46:26)
    6. https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0 (d34dh0r53, 15:47:03)
    7. https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0 (d34dh0r53, 15:47:38)
    8. https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0 (d34dh0r53, 15:47:48)

  9. conclusion (d34dh0r53, 15:48:10)


Meeting ended at 15:50:33 UTC (full logs).

Action items

  1. dmendiza update S-RBAC topic in meeting etherpad


People present (lines said)

  1. d34dh0r53 (61)
  2. gtema (28)
  3. opendevmeet (5)
  4. dmendiza[m] (4)
  5. cardoe (1)
  6. stephenfin (1)


Generated by MeetBot 0.1.4.