#openstack-keystone: keystone

Meeting started by d34dh0r53 at 15:04:27 UTC (full logs).

Meeting summary

    1. https://openinfra.dev/legal/code-of-conduct (d34dh0r53, 15:04:53)

  1. roll call (d34dh0r53, 15:05:07)
  2. review past meeting work items (d34dh0r53, 15:08:08)
    1. https://meetings.opendev.org/meetings/keystone/2025/keystone.2025-07-30-15.20.html (d34dh0r53, 15:08:13)
    2. ACTION: dmendiza look into https://bugs.launchpad.net/keystone/+bug/2119091 (d34dh0r53, 15:09:31)

  3. liaison updates (d34dh0r53, 15:09:35)
  4. specification OAuth 2.0 (hiromu) (d34dh0r53, 15:11:45)
    1. https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext (d34dh0r53, 15:12:31)
    2. https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability (d34dh0r53, 15:12:32)

  5. specification Secure RBAC (dmendiza) (d34dh0r53, 15:12:35)
    1. https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_ (d34dh0r53, 15:12:35)
    2. https://review.opendev.org/c/openstack/devstack/+/956210 (dmendiza[m], 15:14:09)

  6. specification OpenAPI support (gtema) (d34dh0r53, 15:15:22)
    1. https://review.opendev.org/q/topic:%22openapi%22+project:openstack/keystone (d34dh0r53, 15:15:24)

  7. open discussion (d34dh0r53, 15:15:53)
    1. https://review.opendev.org/c/openstack/devstack/+/956111 (dmendiza[m], 15:20:03)
    2. https://docs.openstack.org/keystone/latest/admin/configuration.html#configuring-password-strength-requirements (dmendiza[m], 15:23:20)

  8. bug review (d34dh0r53, 15:34:34)
    1. https://bugs.launchpad.net/keystone/?orderby=-id&start=0 (d34dh0r53, 15:34:37)
    2. https://bugs.launchpad.net/keystone/+bug/2119346 (d34dh0r53, 15:35:52)
    3. https://bugs.launchpad.net/keystone/+bug/2119543 (d34dh0r53, 15:37:12)
    4. https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0 (d34dh0r53, 15:41:56)
    5. https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0 (d34dh0r53, 15:42:24)
    6. https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0 (d34dh0r53, 15:42:50)
    7. https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0 (d34dh0r53, 15:43:24)
    8. https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0 (d34dh0r53, 15:43:48)

  9. conclusion (d34dh0r53, 15:43:58)


Meeting ended at 15:44:32 UTC (full logs).

Action items

  1. dmendiza look into https://bugs.launchpad.net/keystone/+bug/2119091


People present (lines said)

  1. d34dh0r53 (66)
  2. dmendiza[m] (28)
  3. opendevmeet (3)
  4. bbobrov (2)
  5. cardoe (1)


Generated by MeetBot 0.1.4.