#openstack-keystone: keystone

Meeting started by d34dh0r53 at 15:10:26 UTC (full logs).

Meeting summary

    1. https://openinfra.dev/legal/code-of-conduct (d34dh0r53, 15:11:17)

  1. roll call (d34dh0r53, 15:11:26)
  2. review past meeting work items (d34dh0r53, 15:14:50)
    1. https://meetings.opendev.org/meetings/keystone/2025/keystone.2025-08-06-15.04.html (d34dh0r53, 15:14:57)
    2. ACTION: dmendiza look into https://bugs.launchpad.net/keystone/+bug/2119091 (d34dh0r53, 15:18:31)

  3. liaison updates (d34dh0r53, 15:18:41)
  4. specification OAuth 2.0 (hiromu) (d34dh0r53, 15:20:13)
    1. https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext (d34dh0r53, 15:20:16)
    2. https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability (d34dh0r53, 15:20:19)

  5. specification Secure RBAC (dmendiza) (d34dh0r53, 15:20:33)
    1. https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_ (d34dh0r53, 15:20:35)
    2. https://review.opendev.org/c/openstack/devstack/+/956210 (dmendiza[m], 15:23:58)

  6. specification OpenAPI support (gtema) (d34dh0r53, 15:29:45)
    1. https://review.opendev.org/q/topic:%22openapi%22+project:openstack/keystone (d34dh0r53, 15:29:48)
    2. ACTION: gtema to look into https://bugs.launchpad.net/keystone/+bug/2119543 (gtema, 15:30:08)

  7. open discussion (d34dh0r53, 15:30:52)
  8. bug review (d34dh0r53, 15:36:20)
    1. https://bugs.launchpad.net/keystone/?orderby=-id&start=0 (d34dh0r53, 15:36:40)
    2. https://bugs.launchpad.net/keystone/+bug/2119991 (d34dh0r53, 15:37:06)
    3. https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0 (d34dh0r53, 15:49:06)
    4. https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0 (d34dh0r53, 15:49:17)
    5. https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0 (d34dh0r53, 15:49:39)
    6. https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0 (d34dh0r53, 15:50:16)
    7. https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0 (d34dh0r53, 15:50:22)

  9. conclusion (d34dh0r53, 15:50:31)


Meeting ended at 15:51:14 UTC (full logs).

Action items

  1. dmendiza look into https://bugs.launchpad.net/keystone/+bug/2119091
  2. gtema to look into https://bugs.launchpad.net/keystone/+bug/2119543


Action items, by person

  1. gtema
    1. gtema to look into https://bugs.launchpad.net/keystone/+bug/2119543


People present (lines said)

  1. d34dh0r53 (65)
  2. gtema (15)
  3. dmendiza[m] (9)
  4. opendevmeet (3)


Generated by MeetBot 0.1.4.