#openstack-keystone: keystone

Meeting started by d34dh0r53 at 15:04:20 UTC (full logs).

Meeting summary

    1. https://openinfra.dev/legal/code-of-conduct (d34dh0r53, 15:04:27)

  1. roll call (d34dh0r53, 15:04:32)
  2. review past meeting work items (d34dh0r53, 15:06:30)
    1. https://meetings.opendev.org/meetings/keystone/2025/keystone.2025-08-20-15.02.html (d34dh0r53, 15:06:34)
    2. ACTION: dwilde/gtema add PTG topic about service account (d34dh0r53, 15:09:16)

  3. liaison updates (d34dh0r53, 15:09:30)
  4. specification OAuth 2.0 (hiromu) (d34dh0r53, 15:10:25)
    1. https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext (d34dh0r53, 15:10:29)
    2. https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability (d34dh0r53, 15:10:34)

  5. specification Secure RBAC (dmendiza) (d34dh0r53, 15:10:49)
    1. https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_ (d34dh0r53, 15:10:53)

  6. specification OpenAPI support (gtema) (d34dh0r53, 15:12:23)
    1. https://review.opendev.org/q/topic:%22openapi%22+project:openstack/keystone (d34dh0r53, 15:12:25)
    2. https://review.opendev.org/c/openstack/keystone/+/957547 (gtema, 15:13:14)

  7. open discussion (d34dh0r53, 15:15:03)
  8. bug review (d34dh0r53, 15:16:17)
    1. https://bugs.launchpad.net/keystone/?orderby=-id&start=0 (d34dh0r53, 15:16:21)
    2. https://bugs.launchpad.net/keystone/+bug/2121152 (d34dh0r53, 15:17:20)

  9. password regex testing (d34dh0r53, 15:18:10)
    1. https://review.opendev.org/c/openstack/devstack/+/957969 (dmendiza[m], 15:18:32)

  10. bug review (d34dh0r53, 15:25:02)
    1. https://bugs.launchpad.net/keystone/?orderby=-id&start=0 (d34dh0r53, 15:25:13)
    2. https://bugs.launchpad.net/keystone/+bug/2121152 (d34dh0r53, 15:25:42)
    3. https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0 (d34dh0r53, 15:27:31)
    4. https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0 (d34dh0r53, 15:28:15)
    5. https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0 (d34dh0r53, 15:28:45)
    6. https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0 (d34dh0r53, 15:29:14)
    7. https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0 (d34dh0r53, 15:29:27)

  11. conclusion (d34dh0r53, 15:29:41)
    1. https://review.opendev.org/c/openstack/keystone/+/958665 is gate unblocker for 2025.1 (gtema, 15:30:01)


Meeting ended at 15:32:23 UTC (full logs).

Action items

  1. dwilde/gtema add PTG topic about service account


Action items, by person

  1. gtema
    1. dwilde/gtema add PTG topic about service account


People present (lines said)

  1. d34dh0r53 (67)
  2. dmendiza[m] (16)
  3. gtema (14)
  4. opendevmeet (3)
  5. xek (1)


Generated by MeetBot 0.1.4.