#openstack-meeting-4: kuryr

Meeting started by apuimedo at 14:00:38 UTC (full logs).

Meeting summary

    1. vikasc icoughla irenab tango devvesa and apuimedo are present (apuimedo, 14:02:14)

  1. repository organization (apuimedo, 14:02:44)
    1. openstack/kuryr has been cloned to openstack/kuryr-libnetwork by mordred at our request (apuimedo, 14:03:15)
    2. openstack/kuryr should now start dropping the code that is specific to kuryr-libnetwork and become home of the specs and the kuryr-libnetwork python package (apuimedo, 14:04:03)
    3. openstack/kuryr should now start dropping the code that is specific to kuryr-libnetwork and become home of the specs and the kuryr_lib python package (apuimedo, 14:04:17)
    4. openstack/libnetwork should drop the common code and add kuryr_lib to its requirements (apuimedo, 14:04:51)
    5. https://review.openstack.org/#/c/336661/ (vikasc, 14:05:06)
    6. https://review.openstack.org/#/c/336661/ (apuimedo, 14:05:16)
    7. http://lists.openstack.org/pipermail/openstack-dev/2016-July/098692.html (apuimedo, 14:06:28)
    8. http://lists.openstack.org/pipermail/openstack-dev/2016-July/098652.html (apuimedo, 14:08:54)
    9. as per dhellmann's recommendation, the split into repos will not use python namespaces, instead, we'll have three python packages kuryr_lib, kuryr_libnetwork, kuryr_kubernetes (apuimedo, 14:13:17)
    10. ACTION: apuimedo to check how we can run dependent project's gates in kuryr_lib gates (apuimedo, 14:20:44)

  2. container_in_vm (nested) (apuimedo, 14:20:59)
    1. vikasc has been added as an assignee for the spec https://review.openstack.org/#/c/334354/1 (apuimedo, 14:21:32)
    2. ACTION: apuimedo, banix and irenab to review https://review.openstack.org/#/c/336784/ (apuimedo, 14:25:37)

  3. kubernetes (apuimedo, 14:27:09)
    1. ACTION: apuimedo to update the spec patch https://review.openstack.org/330282 (apuimedo, 14:28:04)
    2. ACTION: apuimedo to check the leader election primitives in etcdv3 that was just released (apuimedo, 14:30:03)

  4. open discussion (apuimedo, 14:31:16)
    1. ACTION: irenab apuimedo to review https://review.openstack.org/#/c/307946/ (apuimedo, 14:34:08)


Meeting ended at 14:34:57 UTC (full logs).

Action items

  1. apuimedo to check how we can run dependent project's gates in kuryr_lib gates
  2. apuimedo, banix and irenab to review https://review.openstack.org/#/c/336784/
  3. apuimedo to update the spec patch https://review.openstack.org/330282
  4. apuimedo to check the leader election primitives in etcdv3 that was just released
  5. irenab apuimedo to review https://review.openstack.org/#/c/307946/


Action items, by person

  1. apuimedo
    1. apuimedo to check how we can run dependent project's gates in kuryr_lib gates
    2. apuimedo, banix and irenab to review https://review.openstack.org/#/c/336784/
    3. apuimedo to update the spec patch https://review.openstack.org/330282
    4. apuimedo to check the leader election primitives in etcdv3 that was just released
    5. irenab apuimedo to review https://review.openstack.org/#/c/307946/
  2. irenab
    1. apuimedo, banix and irenab to review https://review.openstack.org/#/c/336784/
    2. irenab apuimedo to review https://review.openstack.org/#/c/307946/
  3. openstack
    1. apuimedo, banix and irenab to review https://review.openstack.org/#/c/336784/
    2. apuimedo to update the spec patch https://review.openstack.org/330282
    3. irenab apuimedo to review https://review.openstack.org/#/c/307946/


People present (lines said)

  1. apuimedo (83)
  2. vikasc (32)
  3. irenab (4)
  4. tango (3)
  5. devvesa (3)
  6. openstack (3)
  7. diga (3)
  8. icoughla (1)


Generated by MeetBot 0.1.4.