#openstack-meeting-alt: Marconi

Meeting started by flaper87 at 15:01:01 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/Marconi#Agenda (alcabrera, 15:01:32)
    2. flaper87 could get fuel out of his coffee... It's soooo deeply dark (flaper87, 15:01:55)

  1. summit (flaper87, 15:02:24)
    1. https://etherpad.openstack.org/p/marconi-icehouse-talk (alcabrera, 15:02:45)
    2. https://etherpad.openstack.org/p/marconi-icehouse-talk (amitgandhi, 15:06:18)
    3. https://etherpad.openstack.org/p/marconi-icehouse-talk (flwang, 15:06:20)
    4. https://etherpad.openstack.org/p/marconi-icehouse-talk (flaper87, 15:06:44)
    5. ACTION: alcabrera to write the talk proposal (flaper87, 15:07:32)
    6. ACTION: alcabrera to force oz_akan to submit an ops-marconi talk proposal. Use brute force if necessary (flaper87, 15:08:59)
    7. contribute towards a great marconi proposal https://etherpad.openstack.org/p/marconi-icehouse-talk (alcabrera, 15:09:02)

  2. sqlalchemy (flaper87, 15:10:32)
    1. https://review.openstack.org/#/c/70202/ (alcabrera, 15:11:31)
    2. https://review.openstack.org/#/c/70946/ (alcabrera, 15:11:47)
    3. https://review.openstack.org/#/c/71335/ (alcabrera, 15:11:56)
    4. https://review.openstack.org/#/c/70947/ (alcabrera, 15:12:09)
    5. https://review.openstack.org/#/q/status:open+project:openstack/marconi+branch:master+topic:bp/sql-storage-driver,n,z (malini, 15:12:12)
    6. https://review.openstack.org/#/c/72677/ (flaper87, 15:12:27)
    7. flaper87 made great progress on message controller (alcabrera, 15:13:23)
    8. shard driver ready for review (alcabrera, 15:13:49)
    9. sqlalchemy on schedule (alcabrera, 15:15:00)
    10. ACTION: malini to unblock herself (flaper87, 15:16:50)

  3. API v1.1 (flaper87, 15:18:22)
    1. ACTION: to beat kgriffs for not being around (flaper87, 15:18:43)

  4. tempest update (flaper87, 15:18:53)
    1. https://review.openstack.org/#/c/63449/ (alcabrera, 15:19:55)
    2. https://review.openstack.org/#/c/72412/ (alcabrera, 15:19:57)
    3. malini making good progress on marconi/temptest integration (alcabrera, 15:20:23)
    4. https://review.openstack.org/#/c/69497/ might end up as a blocker for us (malini, 15:20:44)
    5. extending tempest test suite to include v1.1 not expected to be difficult (alcabrera, 15:24:15)

  5. API v1.1 (flaper87, 15:25:06)
    1. https://wiki.openstack.org/wiki/Marconi/specs/api/v1.1 (flaper87, 15:25:21)
    2. ACTION: send the v1.1 spec to the mailing list (flaper87, 15:31:35)

  6. health endpoint (flaper87, 15:32:33)
    1. ACTION: flaper87 to put the wsgi transport under the v1 version and clone it to v1_1 (flaper87, 15:34:43)
    2. ACTION: flwang to continue work on /health and /ping for v1.1 (alcabrera, 15:35:13)

  7. Grace not required (flaper87, 15:35:58)
    1. /claims grace to be deprecated in v1.1 and removed in v2.0 (alcabrera, 15:41:23)

  8. Add gack and/or pop (flaper87, 15:41:58)
  9. Add gack and/or pop to API v1.1 (flaper87, 15:42:03)
    1. https://wiki.openstack.org/wiki/Marconi/specs/api/v1.1#Claim_Messages (alcabrera, 15:44:10)
    2. gack is already provided as /claim?limit=1 (alcabrera, 15:44:54)
    3. pop seems to be a good idea. It needs further discussion and it may make sense to have it for v1.1 (flaper87, 15:51:55)

  10. Open Discussion (flaper87, 15:52:25)
    1. ACTION: Everyone to thank kgriffs for being so nice and paying for whatever we need at the next summit (flaper87, 15:53:36)
    2. this kgriffs fellow is very generous (alcabrera, 15:53:50)
    3. https://review.openstack.org/#/c/68267/ (alcabrera, 15:55:14)
    4. https://review.openstack.org/#/c/70463/ (alcabrera, 15:55:36)


Meeting ended at 15:57:07 UTC (full logs).

Action items

  1. alcabrera to write the talk proposal
  2. alcabrera to force oz_akan to submit an ops-marconi talk proposal. Use brute force if necessary
  3. malini to unblock herself
  4. to beat kgriffs for not being around
  5. send the v1.1 spec to the mailing list
  6. flaper87 to put the wsgi transport under the v1 version and clone it to v1_1
  7. flwang to continue work on /health and /ping for v1.1
  8. Everyone to thank kgriffs for being so nice and paying for whatever we need at the next summit


Action items, by person

  1. alcabrera
    1. alcabrera to write the talk proposal
    2. alcabrera to force oz_akan to submit an ops-marconi talk proposal. Use brute force if necessary
  2. flaper87
    1. flaper87 to put the wsgi transport under the v1 version and clone it to v1_1
  3. flwang
    1. flwang to continue work on /health and /ping for v1.1
  4. malini
    1. malini to unblock herself
  5. UNASSIGNED
    1. to beat kgriffs for not being around
    2. send the v1.1 spec to the mailing list
    3. Everyone to thank kgriffs for being so nice and paying for whatever we need at the next summit


People present (lines said)

  1. alcabrera (195)
  2. flaper87 (189)
  3. malini (48)
  4. flwang (10)
  5. balajiiyer (5)
  6. cpallares (5)
  7. openstack (3)
  8. amitgandhi (1)


Generated by MeetBot 0.1.4.