#openstack-meeting: nova_api

Meeting started by johnthetubaguy at 12:01:18 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/NovaAPI (johnthetubaguy, 12:01:46)

  1. Liberty Stuff (johnthetubaguy, 12:02:33)
    1. https://etherpad.openstack.org/p/YVR-nova-liberty-summit-action-items (johnthetubaguy, 12:02:39)
    2. https://review.openstack.org/#/c/210131/ (edleafe, 12:05:08)
    3. https://review.openstack.org/#/c/210131/ (johnthetubaguy, 12:05:15)
    4. https://review.openstack.org/#/c/193725/28 (johnthetubaguy, 12:06:52)
    5. https://review.openstack.org/#/c/193725/28/nova/tests/functional/api_samples/legacy_v2/all_extensions/server-get-resp.json.tpl,cm (johnthetubaguy, 12:09:00)
    6. https://review.openstack.org/#/c/193725/28/nova/api/openstack/compute/legacy_v2/contrib/__init__.py,cm (johnthetubaguy, 12:11:47)
    7. Microversion support for python nova client - only patch listed merge (sdague, 12:28:04)
    8. Restructure API tree to remove v3 and other confusing things - holding on ed getting working patch (sdague, 12:28:30)
    9. Microversion bump guidelines - Nova devref merged (sdague, 12:29:05)
    10. Remainging policy moving to API layer - patches up for review, status needed on how far to go (sdague, 12:30:35)
    11. Middleware to relax jsonschema validation on v2.0 - patches up for review (sdague, 12:30:47)
    12. https://wiki.openstack.org/wiki/Nova/Liberty_Release_Schedule (johnthetubaguy, 12:32:29)
    13. drop extensions - no progress (sdague, 12:33:03)
    14. Change default paste pipeline to use v2.1 for v2.0 - no progress (sdague, 12:33:14)
    15. deprecate v2_legacy - no progress (johnthetubaguy, 12:33:40)
    16. python-novaclient microverversion got +2 already, need 1 more +2 https://review.openstack.org/#/q/status:open+project:openstack/python-novaclient+branch:master+topic:bp/api-microversion-support,n,z (eliqiao1, 12:34:49)
    17. python microversion client support approved and headed to the gate (sdague, 12:37:33)
    18. http://specs.openstack.org/openstack/nova-specs/specs/liberty/approved/inject-nmi.html (johnthetubaguy, 12:40:10)
    19. ACTION: johnthetubaguy to catch up with alex_xu and others in his morning about the current state of API efforts (johnthetubaguy, 12:49:03)
    20. ACTION: sdague to update the agenda for this meeting to cover the key focus areas of the API work (johnthetubaguy, 12:50:30)

  2. Open Discussion (johnthetubaguy, 12:50:41)


Meeting ended at 13:01:46 UTC (full logs).

Action items

  1. johnthetubaguy to catch up with alex_xu and others in his morning about the current state of API efforts
  2. sdague to update the agenda for this meeting to cover the key focus areas of the API work


Action items, by person

  1. johnthetubaguy
    1. johnthetubaguy to catch up with alex_xu and others in his morning about the current state of API efforts
  2. sdague
    1. sdague to update the agenda for this meeting to cover the key focus areas of the API work


People present (lines said)

  1. johnthetubaguy (127)
  2. sdague (73)
  3. edleafe (37)
  4. openstack (3)
  5. eliqiao1 (3)
  6. kashyap (2)


Generated by MeetBot 0.1.4.