#openstack-meeting: nova api

Meeting started by alex_xu at 12:00:23 UTC (full logs).

Meeting summary

  1. actions from last meeting (alex_xu, 12:01:55)
    1. https://review.openstack.org/215436 (alex_xu, 12:02:19)
    2. https://review.openstack.org/216784 (alex_xu, 12:02:57)
    3. https://review.openstack.org/#/c/207183/ (alex_xu, 12:06:34)
    4. ACTION: sdague to write up test plan for v2.x nova, alex_xu and gmann_ will work on patches (sdague, 12:10:26)

  2. v2.0 on v2.1 (alex_xu, 12:11:36)
    1. The patch for fixing tempest on extra param is merged https://review.openstack.org/216784 (alex_xu, 12:11:43)
    2. The patch for striping the extra params out is merged https://review.openstack.org/#/c/215436/ (alex_xu, 12:11:51)
    3. The patch for using v2.1 only in api-paste.ini is merging https://review.openstack.org/#/c/214085/ (alex_xu, 12:12:02)
    4. #link https://review.openstack.org/219188 (alex_xu, 12:12:30)
    5. https://review.openstack.org/#/c/217727/ ? (alex_xu, 12:15:37)
    6. https://review.openstack.org/219188 and https://review.openstack.org/#/c/217727/ are last two patches about v2 on v2.1 (alex_xu, 12:17:30)
    7. ACTION: edleafe will update https://review.openstack.org/#/c/217727/ (alex_xu, 12:18:09)

  3. v2.1 default on gate (alex_xu, 12:18:35)
  4. Test collapse of v2.0 and v2.1 (alex_xu, 12:23:53)
    1. all the works of collapse of v2 and v2.1 tests are done, thanks to gmann__ ! (alex_xu, 12:24:24)

  5. Remove extensions (alex_xu, 12:25:30)
    1. Deprecated v2.1 extension options patch is merged https://review.openstack.org/214592 (alex_xu, 12:25:36)
    2. https://review.openstack.org/214601 (alex_xu, 12:25:55)

  6. Removal of v3 naming from source tree (alex_xu, 12:27:46)
    1. https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:x3,n,z (alex_xu, 12:27:54)
    2. https://review.openstack.org/219188 (alex_xu, 12:29:00)

  7. API Documentation Improvement (alex_xu, 12:32:03)
  8. API futures - patches for merge (alex_xu, 12:40:55)
    1. #link https://review.openstack.org/217572 (alex_xu, 12:41:16)

  9. open (alex_xu, 12:44:48)
    1. https://review.openstack.org/187112 (alex_xu, 12:45:10)


Meeting ended at 12:48:03 UTC (full logs).

Action items

  1. sdague to write up test plan for v2.x nova, alex_xu and gmann_ will work on patches
  2. edleafe will update https://review.openstack.org/#/c/217727/


Action items, by person

  1. alex_xu
    1. sdague to write up test plan for v2.x nova, alex_xu and gmann_ will work on patches
  2. edleafe
    1. edleafe will update https://review.openstack.org/#/c/217727/
  3. gmann_
    1. sdague to write up test plan for v2.x nova, alex_xu and gmann_ will work on patches
  4. openstack
    1. edleafe will update https://review.openstack.org/#/c/217727/
  5. sdague
    1. sdague to write up test plan for v2.x nova, alex_xu and gmann_ will work on patches


People present (lines said)

  1. alex_xu (122)
  2. oomichi (35)
  3. gmann__ (26)
  4. sdague (23)
  5. annegentle (17)
  6. edleafe (14)
  7. gmann_ (11)
  8. openstack (3)


Generated by MeetBot 0.1.4.