#openstack-meeting-alt: nova_scheduler

Meeting started by efried at 14:00:03 UTC (full logs).

Meeting summary

    1. agenda https://wiki.openstack.org/wiki/Meetings/NovaScheduler#Agenda_for_next_meeting (efried, 14:01:25)

  1. last meeting (efried, 14:01:42)
    1. last minutes: http://eavesdrop.openstack.org/meetings/nova_scheduler/2018/nova_scheduler.2018-07-16-13.59.html (efried, 14:01:50)

  2. specs and review (efried, 14:02:33)
    1. latest pupdate: http://lists.openstack.org/pipermail/openstack-dev/2018-July/132387.html (efried, 14:03:03)
    2. reshaper series: https://review.openstack.org/#/q/topic:bp/reshape-provider-tree+status:open (efried, 14:04:01)
    3. IndexError when clearing a provider's inventories: https://bugs.launchpad.net/nova/+bug/1783130 (efried, 14:04:42)
    4. reshaper handler & microversion https://review.openstack.org/#/c/576927/ (efried, 14:06:24)
    5. "just fix it" fix for bug 1782340: https://review.openstack.org/#/c/583907/ (efried, 14:07:36)
    6. client side cumulative patch https://review.openstack.org/#/c/576236/ (efried, 14:16:00)
    7. bottom of the new-and-improved reshaper client side series https://review.openstack.org/#/c/584598/ (efried, 14:17:21)
    8. AGREED: to "just fix" https://bugs.launchpad.net/nova/+bug/1782340 via https://review.openstack.org/#/c/583907/ without a microversion. (efried, 14:22:37)
    9. AGREED: to put a procedural hold on the reshaper API change https://review.openstack.org/#/c/576927/ until the client side matures, so we don't burn a microversion. (efried, 14:23:19)
    10. AGREED: no need to pull the db side reshaper patch https://review.openstack.org/#/c/582383/ out of the gate for https://bugs.launchpad.net/nova/+bug/1783130 since it's all new code, no regressions in existing. (efried, 14:24:37)

  3. bugs (efried, 14:24:50)
    1. placement bugs: https://bugs.launchpad.net/nova/+bugs?field.tag=placement&orderby=-id (efried, 14:24:55)

  4. opens (efried, 14:26:05)
    1. consumer generation handling (gibi): https://review.openstack.org/#/c/583667/ (efried, 14:26:21)
    2. library spike: https://github.com/cdent/os-resource-classes (efried, 14:28:12)
    3. placement integration spike: https://review.openstack.org/#/c/584084/ (efried, 14:28:12)
    4. https://etherpad.openstack.org/p/nova-ptg-stein (mriedem, 14:30:15)
    5. jaypipes' os-resource-classes proposal: https://github.com/jaypipes/os-resource-classes (efried, 14:30:17)
    6. Add nova-manage placement sync_aggregates https://review.openstack.org/#/c/575912/ (efried, 14:36:20)


Meeting ended at 14:42:23 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. efried (92)
  2. mriedem (34)
  3. cdent (17)
  4. bauzas (14)
  5. openstack (8)
  6. jaypipes (4)
  7. gibi (3)
  8. takashin (1)
  9. tetsuro (1)
  10. alex_xu (1)


Generated by MeetBot 0.1.4.