#openstack-cyborg: openstack-cyborg

Meeting started by zhipeng at 14:07:01 UTC (full logs).

Meeting summary

  1. Shaohe's PoC demo (zhipeng, 14:07:17)
    1. https://etherpad.openstack.org/p/cyborg-nova-poc (zhipeng, 14:26:18)
    2. https://zoom.us/j/741227793 (zhipeng, 14:33:30)
    3. rename allocation to assignment (jay) (zhipeng, 14:35:02)
    4. cyborg agent does not need to do the allocation, nova sched already took care of that (zhipeng, 14:35:24)
    5. https://etherpad.openstack.org/p/cyborg-nova-poc (shaohe_feng_, 14:36:08)
    6. pci manager has its own concept of the allocation/deallocation (zhipeng, 14:37:28)
    7. cyborg might need to send an exception to nova (zhipeng, 14:39:04)
    8. move claim/release functionality to os-acc (zhipeng, 14:46:34)
    9. AGREED: move claim/release functionality to os-acc (zhipeng, 14:46:47)
    10. AGREED: use common location for the image cache (zhipeng, 14:51:18)
    11. not to use the image cache unless necessary for security concerns (zhipeng, 14:55:09)

  2. Rocky Task Assignment (zhipeng, 15:04:34)
    1. discussing cyborg weigher (zhipeng, 15:04:45)
    2. https://etherpad.openstack.org/p/cyborg-ptg-rocky-recap (zhipeng, 15:04:49)
    3. ACTION: Sundar propose the weigher spec (zhipeng, 15:41:35)
    4. ACTION: Jinghan python-cyborgclient, quota engine, experiment with oslo.limit (zhipeng, 15:42:56)
    5. ACTION: Li Liu programmability spec (zhipeng, 15:44:29)
    6. ACTION: Dutch for Xilinx driver (zhipeng, 15:45:32)
    7. ACTION: zhuli for os-acc spec (zhipeng, 15:46:14)
    8. ACTION: yumeng create cyborg-specs repo, help polishing the docs (zhipeng, 15:46:55)
    9. ACTION: metadata Li Liu spec (zhipeng, 15:47:11)
    10. spec freeze April 20 week (zhipeng, 15:51:12)
    11. driver freeze Jun 08 week (zhipeng, 15:51:26)
    12. feature freeze Jul 27 week (zhipeng, 15:51:40)
    13. oslo.limit could be an exception (zhipeng, 15:51:53)
    14. new repos (cyborgclient, cyborg-spec, os-acc) should be created as soon as possible (zhipeng, 15:52:48)
    15. https://review.openstack.org/#/c/552734/ (Li_Liu, 15:53:29)


Meeting ended at 15:55:22 UTC (full logs).

Action items

  1. Sundar propose the weigher spec
  2. Jinghan python-cyborgclient, quota engine, experiment with oslo.limit
  3. Li Liu programmability spec
  4. Dutch for Xilinx driver
  5. zhuli for os-acc spec
  6. yumeng create cyborg-specs repo, help polishing the docs
  7. metadata Li Liu spec


Action items, by person

  1. Dutch
    1. Dutch for Xilinx driver
  2. zhuli
    1. zhuli for os-acc spec
  3. UNASSIGNED
    1. Sundar propose the weigher spec
    2. Jinghan python-cyborgclient, quota engine, experiment with oslo.limit
    3. Li Liu programmability spec
    4. yumeng create cyborg-specs repo, help polishing the docs
    5. metadata Li Liu spec


People present (lines said)

  1. zhipeng (37)
  2. alex_xu (4)
  3. openstack (3)
  4. kosamara (2)
  5. Dutch (2)
  6. edleafe (2)
  7. Li_Liu (2)
  8. shaohe_feng_ (1)
  9. zhuli (1)
  10. NokMikeR (1)
  11. jaypipes (1)
  12. Vipparthy (1)


Generated by MeetBot 0.1.4.