#openstack-meeting-alt: oslo

Meeting started by dhellmann at 16:00:07 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/Oslo (dhellmann, 16:00:35)

  1. Review action items from previous meeting (dhellmann, 16:02:15)
    1. the wheel publishing change is merged, and some kinks are being worked out (dhellmann, 16:02:22)
    2. dhellmann talked with boris-42 about sending email about having oslo adopt osprofiler (dhellmann, 16:04:13)
    3. updated the review links section of the wiki based on sdague’s new dashboard creation tool (dhellmann, 16:04:36)
    4. https://github.com/sdague/gerrit-dash-creator (dhellmann, 16:04:43)

  2. Red flags from liaisons (dhellmann, 16:06:52)
  3. Blueprint approval process (dhellmann, 16:11:43)
    1. ACTION: beekneemech send email to openstack-dev with oslo spec approval policy (dhellmann, 16:23:07)
    2. AGREED: oslo-specs approvals are left up to the PTL, after consensus is reached, with an option to delegate to the lead maintainer for each library (dhellmann, 16:23:57)

  4. Blueprint priorities (dhellmann, 16:24:54)
    1. https://blueprints.launchpad.net/oslo/juno (dhellmann, 16:25:09)
    2. https://blueprints.launchpad.net/oslo.messaging/juno (dhellmann, 16:25:09)
    3. https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/oslo-messaging,n,z (markmc, 16:36:44)
    4. https://review.openstack.org/#/q/status:open+project:openstack/heat+branch:master+topic:bp/oslo-messaging,n,z (markmc, 16:36:45)

  5. oslotest adoption status (dhellmann, 16:38:41)
    1. https://review.openstack.org/87727 (dhellmann, 16:38:56)
    2. ACTION: beekneemech update the graduation checklist to include a step to remove use of oslo logging in favor of stdlib logging (dhellmann, 16:39:36)

  6. oslo.messaging adoption status (dhellmann, 16:40:32)
  7. oslo.db graduation status (dhellmann, 16:41:27)
    1. https://etherpad.openstack.org/p/oslo.db-release-blockers (rpodolyaka, 16:41:47)
    2. https://etherpad.openstack.org/p/oslo.db-release-blockers (viktors, 16:41:56)
    3. https://review.openstack.org/#/c/96468/ - the spec we need to get approved (rpodolyaka, 16:42:39)

  8. oslo.i18n graduation status (dhellmann, 16:45:50)
    1. https://review.openstack.org/#/q/status:open+project:openstack/oslo.i18n,n,z (dhellmann, 16:45:50)
    2. ACTION: dhellmann approve graduate-oslo-db and graduate-oslo-i18n specs in that order (dhellmann, 16:47:11)

  9. review priorities for this week (dhellmann, 16:47:43)
  10. open discussion (dhellmann, 16:50:42)
    1. ACTION: liaisons review https://review.openstack.org/#/c/95281 (dhellmann, 16:51:31)
    2. ACTION: dhellmand send email to the dev list asking for liaisons to review https://review.openstack.org/#/c/95281 (dhellmann, 16:51:52)


Meeting ended at 16:55:18 UTC (full logs).

Action items

  1. beekneemech send email to openstack-dev with oslo spec approval policy
  2. beekneemech update the graduation checklist to include a step to remove use of oslo logging in favor of stdlib logging
  3. dhellmann approve graduate-oslo-db and graduate-oslo-i18n specs in that order
  4. liaisons review https://review.openstack.org/#/c/95281
  5. dhellmand send email to the dev list asking for liaisons to review https://review.openstack.org/#/c/95281


Action items, by person

  1. beekneemech
    1. beekneemech send email to openstack-dev with oslo spec approval policy
    2. beekneemech update the graduation checklist to include a step to remove use of oslo logging in favor of stdlib logging
  2. dhellmann
    1. dhellmann approve graduate-oslo-db and graduate-oslo-i18n specs in that order
  3. openstack
    1. beekneemech send email to openstack-dev with oslo spec approval policy
    2. liaisons review https://review.openstack.org/#/c/95281
    3. dhellmand send email to the dev list asking for liaisons to review https://review.openstack.org/#/c/95281


People present (lines said)

  1. dhellmann (128)
  2. beekneemech (52)
  3. markmc (22)
  4. rpodolyaka (18)
  5. jogo (8)
  6. bknudson (7)
  7. viktors (5)
  8. boris-42 (3)
  9. openstack (3)
  10. morganfainberg (2)
  11. sileht (1)
  12. jd__ (1)


Generated by MeetBot 0.1.4.