#openstack-meeting-alt: oslo

Meeting started by dhellmann at 16:00:12 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting (dhellmann, 16:00:12)

  1. Review action items from previous meeting (dhellmann, 16:02:02)
    1. bnemec and dims to try get oslo.serialization out next week (dhellmann, 16:02:24)
    2. dims to chase oslo.utils adoption in stables branches (dhellmann, 16:02:39)
    3. viktors to look at merging run_cross_tests.sh in oslo.db (dhellmann, 16:03:40)

  2. Feature Freeze Exceptions (dhellmann, 16:05:48)
    1. AMQP 1.0 driver for oslo.messaging was given an FFE (dhellmann, 16:05:53)

  3. Other RC-1 Work (dhellmann, 16:08:09)
    1. https://etherpad.openstack.org/p/juno-oslo-feature-freeze (dhellmann, 16:08:28)

  4. finishing the juno libraries (dhellmann, 16:12:29)
    1. https://docs.google.com/spreadsheets/d/1MvXsg0XxPonJ8yAFSraIwHM940eAfoXhfBVRa6hN7MY/edit#gid=0 (dhellmann, 16:12:58)

  5. Summit Planning (dhellmann, 16:21:37)
    1. https://etherpad.openstack.org/p/kilo-oslo-summit-topics (dhellmann, 16:21:56)

  6. oslo.serialization (dhellmann, 16:26:07)
    1. https://review.openstack.org/#/q/project:openstack%2Foslo.serialization+is:open,n,z (dhellmann, 16:26:36)

  7. oslo.log (dhellmann, 16:28:34)
    1. https://review.openstack.org/#/q/project:openstack/oslo.log+is:open,n,z (dhellmann, 16:28:41)

  8. oslo.utils (dhellmann, 16:30:34)
    1. https://review.openstack.org/#/q/project:openstack/oslo.utils+is:open,n,z (dhellmann, 16:30:42)

  9. oslo.db (dhellmann, 16:32:40)
    1. https://review.openstack.org/#/q/project:openstack/oslo.db+is:open,n,z (dhellmann, 16:32:56)
    2. https://review.openstack.org/#/c/116324/ looks like the hot one (zzzeek, 16:34:25)
    3. https://etherpad.openstack.org/p/juno-oslo-feature-freeze (dhellmann, 16:35:57)

  10. oslo.messaging (dhellmann, 16:41:09)
    1. https://review.openstack.org/#/q/project:openstack/oslo.messaging+is:open,n,z (dhellmann, 16:41:31)

  11. oslotest (dhellmann, 16:43:57)
    1. https://review.openstack.org/#/q/project:openstack/oslotest+is:open,n,z (dhellmann, 16:44:09)

  12. cliff (dhellmann, 16:47:11)
    1. release planned for monday, long overdue (dhellmann, 16:47:16)

  13. pbr (dhellmann, 16:47:42)
    1. release planned for monday, also overdue (dhellmann, 16:47:42)

  14. oslo.i18n (dhellmann, 16:47:49)
  15. stevedore (dhellmann, 16:49:41)
    1. ACTION: dhellmann ensure stevedore builds universal wheels (dhellmann, 16:52:36)

  16. oslo.rootwrap (dhellmann, 16:53:33)
    1. ACTION: dhellmann verify with ttx that oslo.rootwrap is still ok for a 1.0 release (dhellmann, 16:54:42)

  17. oslo.utils version (dhellmann, 16:54:45)
    1. oslo.utils will be released as 1.0 this cycle (dhellmann, 16:56:12)

  18. when to branch stable/juno (or proposed) (dhellmann, 16:56:21)
  19. review priorities for this week (dhellmann, 16:58:50)
  20. open discussion (dhellmann, 16:59:32)


Meeting ended at 17:01:05 UTC (full logs).

Action items

  1. dhellmann ensure stevedore builds universal wheels
  2. dhellmann verify with ttx that oslo.rootwrap is still ok for a 1.0 release


Action items, by person

  1. dhellmann
    1. dhellmann ensure stevedore builds universal wheels
    2. dhellmann verify with ttx that oslo.rootwrap is still ok for a 1.0 release


People present (lines said)

  1. dhellmann (172)
  2. flaper87 (19)
  3. beekneemech (17)
  4. viktors (13)
  5. bknudson (10)
  6. zzzeek (8)
  7. YorikSar (8)
  8. dims (8)
  9. kgiusti (7)
  10. dimsum_ (3)
  11. morganfainberg (3)
  12. openstack (3)
  13. dims_ (1)
  14. tedross (1)
  15. i159 (1)
  16. jecarey (1)


Generated by MeetBot 0.1.4.