#openstack-meeting-alt: oslo

Meeting started by dhellmann at 16:00:10 UTC (full logs).

Meeting summary

  1. Review action items from previous meeting (dhellmann, 16:02:58)
    1. dhellmann sign up as documentation liaison DONE (dhellmann, 16:03:07)
    2. dhellmann make sure instructions for creating a new library are up to date with stable requirements jobs (dhellmann, 16:03:20)
    3. https://review.openstack.org/137451 (dhellmann, 16:03:21)
    4. sileht talk to devstack team about updating to not install oslo from source in stable branches (dhellmann, 16:04:48)
    5. ACTION: sileht talk to devstack team about updating to not install oslo from source in stable branches (dhellmann, 16:06:33)

  2. tagging releases (dhellmann, 16:06:39)
    1. ACTION: dhellmann to release cliff (dhellmann, 16:06:55)
    2. ACTION: bnemec to release oslo.concurrency (dhellmann, 16:06:55)
    3. ACTION: dims to release oslo.utils (dhellmann, 16:06:55)
    4. ACTION: dhellmann to release oslo.config (dhellmann, 16:06:55)
    5. ACTION: sileht to release oslo.messaging (dhellmann, 16:06:56)
    6. ACTION: viktors to release oslo.db (dhellmann, 16:06:57)
    7. ACTION: dims to release oslo.1i8n (dhellmann, 16:06:58)
    8. ACTION: jd__ to release oslo.middleware (dhellmann, 16:06:59)
    9. ACTION: dhellmann to release oslo.rootwrap (or talk to ttx about doing it) (dhellmann, 16:07:00)
    10. ACTION: bnemec to release oslo.serialization (dhellmann, 16:07:01)
    11. ACTION: dims to release oslo.vmware (dhellmann, 16:07:02)
    12. ACTION: dhellmann to release oslosphinx (dhellmann, 16:07:03)
    13. ACTION: dhellmann to release oslotest (dhellmann, 16:07:04)
    14. ACTION: harlowja to release taskflow (dhellmann, 16:07:05)
    15. ACTION: dhellmann update release instructions after https://review.openstack.org/#/c/136401/ is merged (dhellmann, 16:10:22)

  3. Red flags for/from liaisons (dhellmann, 16:11:34)
    1. https://review.openstack.org/#/c/93558/ here is one important (i159, 16:12:28)
    2. https://review.openstack.org/#/c/93558/ has strange gate problems but it has uncovered a bunch of db dugs (i159, 16:13:32)
    3. keeping an eye on https://review.openstack.org/#/c/93558/ for the keystone team (dhellmann, 16:14:12)

  4. Sprint planning (dhellmann, 16:17:20)
    1. https://etherpad.openstack.org/p/oslo-kilo-sprint (dhellmann, 16:17:31)
    2. ACTION: dhellmann announce sprint on the dev mailing list (dhellmann, 16:20:02)

  5. Spec reviews (dhellmann, 16:22:05)
    1. https://review.openstack.org/#/q/project:openstack%2Foslo-specs+is:open,n,z (dhellmann, 16:22:12)
    2. https://review.openstack.org/#/c/112842/ significant one (i159, 16:22:40)
    3. https://review.openstack.org/#/c/131666/ has 2 +2 (dhellmann, 16:22:45)
    4. https://review.openstack.org/#/c/133668/ and about messaging (i159, 16:23:48)
    5. ACTION: dhellmann approve spec https://review.openstack.org/#/c/127532/ (dhellmann, 16:26:15)
    6. ACTION: dhellmann approve spec https://review.openstack.org/#/c/131666/ (dhellmann, 16:26:36)
    7. https://review.openstack.org/#/c/132551/ is the app-agnostic-logging spec from last cycle. It has 1 +2, and it looks like I owe bnemec a response there (dhellmann, 16:27:53)
    8. https://review.openstack.org/#/c/124847/ is the spec for removing the context adapter from oslo.log (dhellmann, 16:28:36)
    9. ACTION: dhellmann approve spec https://review.openstack.org/#/c/124847/ (dhellmann, 16:28:55)
    10. I'll approve all of those tomorrow unless someone objects today. (dhellmann, 16:29:07)

  6. Stable maintenance liaison (dhellmann, 16:33:07)
    1. http://lists.openstack.org/pipermail/openstack-dev/2014-November/050390.html (dhellmann, 16:33:16)

  7. Ongoing work & Review priorities (dhellmann, 16:36:10)
    1. https://launchpad.net/oslo/+milestone/next-kilo (dhellmann, 16:36:15)
    2. https://launchpad.net/oslo/+milestone/kilo-1 (dhellmann, 16:36:18)

  8. open discussion (dhellmann, 16:40:48)


Meeting ended at 16:44:07 UTC (full logs).

Action items

  1. sileht talk to devstack team about updating to not install oslo from source in stable branches
  2. dhellmann to release cliff
  3. bnemec to release oslo.concurrency
  4. dims to release oslo.utils
  5. dhellmann to release oslo.config
  6. sileht to release oslo.messaging
  7. viktors to release oslo.db
  8. dims to release oslo.1i8n
  9. jd__ to release oslo.middleware
  10. dhellmann to release oslo.rootwrap (or talk to ttx about doing it)
  11. bnemec to release oslo.serialization
  12. dims to release oslo.vmware
  13. dhellmann to release oslosphinx
  14. dhellmann to release oslotest
  15. harlowja to release taskflow
  16. dhellmann update release instructions after https://review.openstack.org/#/c/136401/ is merged
  17. dhellmann announce sprint on the dev mailing list
  18. dhellmann approve spec https://review.openstack.org/#/c/127532/
  19. dhellmann approve spec https://review.openstack.org/#/c/131666/
  20. dhellmann approve spec https://review.openstack.org/#/c/124847/


Action items, by person

  1. bnemec
    1. bnemec to release oslo.concurrency
    2. bnemec to release oslo.serialization
  2. dhellmann
    1. dhellmann to release cliff
    2. dhellmann to release oslo.config
    3. dhellmann to release oslo.rootwrap (or talk to ttx about doing it)
    4. dhellmann to release oslosphinx
    5. dhellmann to release oslotest
    6. dhellmann update release instructions after https://review.openstack.org/#/c/136401/ is merged
    7. dhellmann announce sprint on the dev mailing list
    8. dhellmann approve spec https://review.openstack.org/#/c/127532/
    9. dhellmann approve spec https://review.openstack.org/#/c/131666/
    10. dhellmann approve spec https://review.openstack.org/#/c/124847/
  3. dims
    1. dims to release oslo.utils
    2. dims to release oslo.1i8n
    3. dims to release oslo.vmware
  4. jd__
    1. jd__ to release oslo.middleware
  5. openstack
    1. dhellmann update release instructions after https://review.openstack.org/#/c/136401/ is merged
    2. dhellmann approve spec https://review.openstack.org/#/c/127532/
    3. dhellmann approve spec https://review.openstack.org/#/c/131666/
    4. dhellmann approve spec https://review.openstack.org/#/c/124847/
  6. viktors
    1. viktors to release oslo.db
  7. UNASSIGNED
    1. sileht talk to devstack team about updating to not install oslo from source in stable branches
    2. sileht to release oslo.messaging
    3. harlowja to release taskflow


People present (lines said)

  1. dhellmann (98)
  2. i159 (12)
  3. bnemec (11)
  4. harlowja_at_home (4)
  5. viktors (4)
  6. jungleboyj (3)
  7. dims (3)
  8. openstack (3)
  9. bknudson (2)
  10. rpodolyaka1 (1)
  11. jd__ (1)
  12. zzzeek (1)
  13. kgiusti (1)


Generated by MeetBot 0.1.4.