#openstack-meeting-alt: oslo

Meeting started by dhellmann at 16:00:18 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/Oslo (dhellmann, 16:00:30)

  1. Review action items from previous meeting (dhellmann, 16:02:03)
    1. dhellmann email dev list reminding oslo contributors to be ready to discuss schedule at the next meeting DONE (dhellmann, 16:02:13)
    2. dhellmann talk to gordc about releasing oslo.middleware DONE (dhellmann, 16:02:26)
    3. dhellmann release oslo.concurrency DONE (dhellmann, 16:02:29)

  2. Red flags for/from liaisons (dhellmann, 16:02:55)
    1. ACTION: bknudson to work on patch to add fixture for timeutils in oslo.utils (dhellmann, 16:13:33)

  3. kilo-2 status review (dhellmann, 16:14:55)
    1. https://launchpad.net/oslo/+milestone/kilo-2 (dhellmann, 16:14:58)

  4. Drop our use of namespace packages (dhellmann, 16:15:18)
    1. https://blueprints.launchpad.net/oslo-incubator/+spec/drop-namespace-packages (dhellmann, 16:15:18)
    2. https://review.openstack.org/#/c/144794/2 (dhellmann, 16:15:42)
    3. https://review.openstack.org/145924 (dhellmann, 16:15:42)
    4. https://github.com/openstack/nova/blob/master/nova/hacking/checks.py#L452 (bknudson, 16:26:45)

  5. graduate oslo.context (dhellmann, 16:29:15)
    1. https://blueprints.launchpad.net/oslo-incubator/+spec/graduate-oslo-context (dhellmann, 16:29:21)
    2. https://review.openstack.org/#/c/140149/ (dhellmann, 16:29:41)

  6. adopt debtcollector library (dhellmann, 16:31:12)
    1. https://blueprints.launchpad.net/oslo-incubator/+spec/adopt-debtcollector (dhellmann, 16:31:16)

  7. graduate oslo.policy (dhellmann, 16:32:59)
    1. https://blueprints.launchpad.net/oslo-incubator/+spec/graduate-policy (dhellmann, 16:33:05)
    2. https://github.com/rodrigods/oslo.policy (dhellmann, 16:34:58)
    3. https://launchpad.net/~oslo-policy-core (ayoung, 16:52:45)

  8. notification dispatcher filter (dhellmann, 16:55:25)
    1. https://blueprints.launchpad.net/oslo.messaging/+spec/notification-dispatcher-filter (dhellmann, 16:55:28)

  9. application-agnostic logging parameters in format strings (dhellmann, 16:59:06)
    1. https://blueprints.launchpad.net/oslo.log/+spec/app-agnostic-logging-parameters (dhellmann, 16:59:06)

  10. semantic version support for pbr (dhellmann, 16:59:49)
    1. https://blueprints.launchpad.net/pbr/+spec/pbr-semver (dhellmann, 16:59:49)

  11. open discussion (dhellmann, 17:00:02)


Meeting ended at 17:01:08 UTC (full logs).

Action items

  1. bknudson to work on patch to add fixture for timeutils in oslo.utils


Action items, by person

  1. bknudson
    1. bknudson to work on patch to add fixture for timeutils in oslo.utils


People present (lines said)

  1. dhellmann (138)
  2. ayoung (46)
  3. bknudson (28)
  4. jungleboyj (19)
  5. bnemec (7)
  6. zzzeek (7)
  7. sileht (5)
  8. morganfainberg (4)
  9. openstack (4)
  10. rpodolyaka1 (3)
  11. jd__ (2)
  12. flaper87 (2)
  13. dims__ (1)


Generated by MeetBot 0.1.4.