#openstack-meeting: puppet-openstack

Meeting started by crinkle at 14:00:58 UTC (full logs).

Meeting summary

  1. Vancouver summit (crinkle, 14:01:32)
    1. https://etherpad.openstack.org/p/puppet-vancouver-summit-proposal (EmilienM, 14:01:39)
    2. ACTION: EmilienM to start an abstract on the etherpad (EmilienM, 14:06:43)

  2. Ops midcycle (crinkle, 14:09:09)
    1. https://etherpad.openstack.org/p/PHL-ops-meetup (crinkle, 14:10:53)
    2. ACTION: Ask mailing list for help preparing ops midcycle agenda (crinkle, 14:15:41)

  3. openstackclient patches (crinkle, 14:16:59)
    1. https://review.openstack.org/145861 (crinkle, 14:17:47)
    2. https://review.openstack.org/145986 (crinkle, 14:17:57)
    3. https://review.openstack.org/145987 (crinkle, 14:18:07)
    4. ACTION: crinkle will update the mailing list when openstackclient patches are merged and stable (crinkle, 14:20:59)
    5. Next steps are updating the patches to allow keystone v3 (richm) and updating the rest of the modules to use openstackclient (crinkle) (crinkle, 14:21:59)

  4. rabbitmq (crinkle, 14:23:53)
    1. https://github.com/puppetlabs/puppetlabs-rabbitmq/blob/master/CHANGELOG.md (crinkle, 14:26:01)
    2. : https://review.openstack.org/144745 (bogdando, 14:31:19)
    3. ACTION: crinkle will submit patches to puppet-nova and puppet-cinder to add deprecation warning for setting up the rabbitmq server (crinkle, 14:35:44)
    4. ACTION: also modify the rabbitmq class to not require setting up the server (bogdando - https://review.openstack.org/144745) (crinkle, 14:41:21)

  5. puppet-group members (crinkle, 14:42:43)
    1. https://groups.google.com/a/puppetlabs.com/forum/#!topic/puppet-openstack/t8hYgzceOdM (EmilienM, 14:42:54)
    2. ACTION: EmilienM to update the list and communicate on the ML about the update (EmilienM, 14:48:21)

  6. open discussion (crinkle, 14:48:52)
    1. https://etherpad.openstack.org/p/puppet-integration-in-heat-tripleo (EmilienM, 14:50:41)


Meeting ended at 14:58:52 UTC (full logs).

Action items

  1. EmilienM to start an abstract on the etherpad
  2. Ask mailing list for help preparing ops midcycle agenda
  3. crinkle will update the mailing list when openstackclient patches are merged and stable
  4. crinkle will submit patches to puppet-nova and puppet-cinder to add deprecation warning for setting up the rabbitmq server
  5. also modify the rabbitmq class to not require setting up the server (bogdando - https://review.openstack.org/144745)
  6. EmilienM to update the list and communicate on the ML about the update


Action items, by person

  1. bogdando
    1. also modify the rabbitmq class to not require setting up the server (bogdando - https://review.openstack.org/144745)
  2. crinkle
    1. crinkle will update the mailing list when openstackclient patches are merged and stable
    2. crinkle will submit patches to puppet-nova and puppet-cinder to add deprecation warning for setting up the rabbitmq server
  3. EmilienM
    1. EmilienM to start an abstract on the etherpad
    2. EmilienM to update the list and communicate on the ML about the update
  4. openstack
    1. also modify the rabbitmq class to not require setting up the server (bogdando - https://review.openstack.org/144745)


People present (lines said)

  1. EmilienM (79)
  2. crinkle (64)
  3. dprince (16)
  4. spredzy (15)
  5. mfisch (13)
  6. bogdando (6)
  7. mdorman (5)
  8. xingchao (3)
  9. sbadia (3)
  10. openstack (3)
  11. fc__ (1)


Generated by MeetBot 0.1.4.