#openstack-meeting: quantum

Meeting started by danwent at 21:00:28 UTC (full logs).

Meeting summary

    1. agenda: http://wiki.openstack.org/Network/Meetings (danwent, 21:00:39)
    2. ok folks, take a deep breath and get ready for a week of crazy reviewing. We're one week out from G-3! (danwent, 21:01:05)
    3. all BPs must be in for review by tomorrow. core devs, don't be afraid to call BS on something that is "in review" in name only (danwent, 21:01:51)
    4. good news is that we're seeing more green on https://launchpad.net/quantum/+milestone/grizzly-3 (danwent, 21:02:35)
    5. bad news i that there's still a ton to review, likely more than we can do a good job on reviewing. (danwent, 21:03:01)
    6. we still have 20 items outstanding for G-3 (danwent, 21:03:41)
    7. We will not be giving feature freeze exceptions for non high/critical issues. (danwent, 21:03:54)
    8. Remember to file doc bugs as we merge in G-3 features. (danwent, 21:04:02)

  1. important bug review (markmcclain ) (danwent, 21:05:05)
    1. https://bugs.launchpad.net/quantum/+bug/1080846 (markmcclain, 21:06:43)
    2. https://bugs.launchpad.net/quantum/+bug/1076179 (salv-orlando, 21:08:15)

  2. api team (salv-orlando) (danwent, 21:12:11)
  3. l3/ipam/dhcp (danwent, 21:14:12)
    1. https://review.openstack.org/#/c/21049/ (markmcclain, 21:15:44)
    2. https://bugs.launchpad.net/openstack-manuals/+bug/1099837 (markmcclain, 21:20:43)
    3. https://blueprints.launchpad.net/openstack/?searchtext=quantum-l3-routing-plugin (markmcclain, 21:22:33)
    4. https://blueprints.launchpad.net/quantum/+spec/quantum-l3-routing-plugin (markmcclain, 21:22:47)
    5. https://review.openstack.org/#/c/21265/ (nati_ueno, 21:27:30)

  4. nova-quantum integration (garyk) (danwent, 21:31:28)
  5. security /firewalling (arosen) (danwent, 21:37:04)
    1. https://review.openstack.org/#/c/21041/ (arosen, 21:38:42)

  6. lbaas team (danwent) (danwent, 21:41:39)
  7. quantumclient / cli (markmcclain, yong is out) (danwent, 21:45:13)
    1. python-quantumclient release status for 3.0: https://launchpad.net/python-quantumclient/+milestone/3.0.0 (danwent, 21:45:48)
    2. ACTION: markmcclain and yong to decide freeze policy (markmcclain, 21:48:57)
    3. ACTION: : markmcclain and yong to drive discussion on pythonquantumclient versioning (danwent, 21:49:18)

  8. quantum stable (garyk) (danwent, 21:50:15)
    1. quantum stable reviews: https://review.openstack.org/#/q/status:open+project:openstack/quantum+branch:stable/folsom,n,z (danwent, 21:50:30)

  9. quantum + horizon (danwent, 21:51:51)
  10. new proposed plugins (danwent, 21:53:58)
    1. ml2 plugin good to go in grizzly, pending core dev reviews (danwent, 21:58:59)
    2. plumgride plugin ok to post for review in grizzly, will merge subject to core team reviews. emagana is core dev. (danwent, 22:05:07)
    3. mido net plugin ok for posting review by EOD tomorrow for grizzly, will merge subjec to core team reviews. markmcclain wiill be core dev if code is posted. (danwent, 22:05:47)

  11. open discussion (danwent, 22:05:53)


Meeting ended at 22:07:31 UTC (full logs).

Action items

  1. markmcclain and yong to decide freeze policy
  2. : markmcclain and yong to drive discussion on pythonquantumclient versioning


Action items, by person

  1. markmcclain
    1. markmcclain and yong to decide freeze policy
    2. : markmcclain and yong to drive discussion on pythonquantumclient versioning


People present (lines said)

  1. danwent (163)
  2. markmcclain (38)
  3. nati_ueno (24)
  4. garyk (21)
  5. salv-orlando (18)
  6. amotoki (14)
  7. PopeAdolfTheFirs (8)
  8. emagana (8)
  9. rkukura (7)
  10. uvirtbot (5)
  11. arosen (4)
  12. enikanorov (4)
  13. openstack (3)
  14. mlavalle (3)
  15. shiv (2)
  16. zyluo (2)
  17. Shree-HP (1)
  18. mestery (1)
  19. yamahata (1)
  20. SumitNaiksatam (1)
  21. annegentle (1)
  22. ilyashakhat (1)


Generated by MeetBot 0.1.4.