#openstack-meeting: Rally

Meeting started by boris-42 at 14:00:49 UTC (full logs).

Meeting summary

  1. Rally Meeting Agenda (finally we did it) (boris-42, 14:05:14)
    1. https://wiki.openstack.org/wiki/Rally#Project_Info (rvasilets, 14:06:48)
    2. https://wiki.openstack.org/wiki/Meetings/Rally (rvasilets, 14:07:04)
    3. https://wiki.openstack.org/wiki/Meetings/Rally (e0ne, 14:07:36)
    4. IDEA: we should try to use all this meetbot stuff, and not bother people with making meeting summary by hand (andreykurilin, 14:15:50)
    5. HELP: (rvasilets, 14:16:15)
    6. https://wiki.debian.org/MeetBot (redixin, 14:16:25)
    7. https://wiki.debian.org/MeetBot (redixin, 14:16:31)
    8. AGREED: We should use https://wiki.debian.org/MeetBot tags (boris-42, 14:19:17)
    9. AGREED: We should write summaries by hand (boris-42, 14:19:41)
    10. AGREED: we should rotate each 2 weeks meeting manager (boris-42, 14:19:57)
    11. ACTION: We should create list of people who would like to help with task (boris-42, 14:20:14)

  2. Ironic benchmarks (boris-42, 14:20:40)
    1. http://logs.openstack.org/64/186064/14/experimental/gate-rally-dsvm-ironic-rally/9b0a8d7/console.html#_2015-06-30_14_39_09_363 (rvasilets, 14:22:38)
    2. http://logs.openstack.org/64/186064/14/experimental/gate-rally-dsvm-ironic-rally/9b0a8d7/console.html.gz#_2015-06-30_14_39_09_363 rvasilets this one shoudl work (boris-42, 14:23:52)
    3. http://logs.openstack.org/64/186064/14/experimental/gate-rally-dsvm-ironic-rally/9b0a8d7/console.html.gz#_2015-06-30_14_39_09_363 (boris-42, 14:23:59)
    4. HELP: Is there someone who can help me with that? (rvasilets, 14:26:06)
    5. ACTION: rvasilets will try to understand why Ironic benchmarks doesn't work and why CLI of ironic works (boris-42, 14:30:24)
    6. ACTION: boris-42 will review Ironic patch https://review.openstack.org/#/c/186064/ (boris-42, 14:30:44)

  3. Use DDT framework in tests (boris-42, 14:31:11)
    1. IDEA: tag?) (rvasilets, 14:31:47)
    2. sample of DDT way to test https://github.com/openstack/rally/blob/master/tests/unit/plugins/openstack/scenarios/manila/test_utils.py#L117-L133 (boris-42, 14:33:30)
    3. yfried: so what we need for now is to block intorducing new cases where DDT should be used (boris-42, 14:38:52)

  4. Optimize Rally imports (boris-42, 14:45:58)
    1. https://review.openstack.org/#/c/196493/ and here is the result of my work (boris-42, 14:46:32)
    2. AGREED: That patch should be merged =) (boris-42, 14:49:37)
    3. AGREED: That patch should be merged =) (boris-42, 14:49:43)

  5. Some review work update (boris-42, 14:49:52)
    1. https://etherpad.openstack.org/p/rally_review_work (kun_huang, 14:50:21)
    2. ACTION: Do the changes with rally dashboard to fit kun_huang requirments) (boris-42, 14:56:33)
    3. IDEA: e.g. review the oldest patches firstly * (boris-42, 14:59:20)


Meeting ended at 15:00:05 UTC (full logs).

Action items

  1. We should create list of people who would like to help with task
  2. rvasilets will try to understand why Ironic benchmarks doesn't work and why CLI of ironic works
  3. boris-42 will review Ironic patch https://review.openstack.org/#/c/186064/
  4. Do the changes with rally dashboard to fit kun_huang requirments)


Action items, by person

  1. boris-42
    1. boris-42 will review Ironic patch https://review.openstack.org/#/c/186064/
  2. kun_huang
    1. Do the changes with rally dashboard to fit kun_huang requirments)
  3. openstack
    1. boris-42 will review Ironic patch https://review.openstack.org/#/c/186064/
  4. rvasilets
    1. rvasilets will try to understand why Ironic benchmarks doesn't work and why CLI of ironic works


People present (lines said)

  1. boris-42 (111)
  2. rvasilets (33)
  3. yfried (22)
  4. kun_huang (15)
  5. stpierre (9)
  6. e0ne (9)
  7. andreykurilin (8)
  8. amaretskiy (7)
  9. redixin (6)
  10. yingjun (3)
  11. openstack (3)
  12. skraynev (3)
  13. temujin (2)


Generated by MeetBot 0.1.4.