#openstack-meeting-alt: reddwarf

Meeting started by vipul at 22:00:12 UTC (full logs).

Meeting summary

    1. Agenda: http://wiki.openstack.org/Meetings/RedDwarfMeeting (vipul, 22:00:42)
    2. no one watches the mailing list but hub_cap (hub_cap, 22:01:50)

  1. Action Item Review (vipul, 22:02:22)
    1. https://github.com/dkehn/devstack (vipul, 22:05:24)
    2. https://blueprints.launchpad.net/reddwarf/+spec/reddwarf-devstack-integration (SlickNik, 22:07:12)
    3. ACTION: dkehn to discuss offline about keystone users required by Redstack (vipul, 22:07:44)
    4. ACTION: vipul to file bug to convert image building to tripleo image builder (vipul, 22:12:36)
    5. tripleo image builder repo is under stackforge now. (SlickNik, 22:14:38)
    6. https://github.com/stackforge/diskimage-builder (SlickNik, 22:15:33)
    7. ACTION: vipul to discuss percona baked into image with hub_cap (vipul, 22:16:48)
    8. oslo upgrade close, couple more days (vipul, 22:19:21)
    9. ACTION: SlickNik and steveleon to look into default guest user (vipul, 22:20:48)
    10. real-mode tests still not completely working (vipul, 22:23:00)
    11. ACTION: esp1 grapex to continue working on fixing all real-mode tests (vipul, 22:23:29)
    12. ACTION: hub_cap to work on moving the extensions for mgmt api to public (hub_cap, 22:26:19)
    13. real mode tests for management api require nova extensions (vipul, 22:30:08)
    14. OVZ impl requires some refactoring around volumes (vipul, 22:30:59)
    15. Rax may dedicate resource to OVZ (vipul, 22:31:08)
    16. ACTION: hub_cap to provide another update on OVZ (vipul, 22:31:27)
    17. devstack integration will need to support nova extensions if we want to test management API in tempest. (SlickNik, 22:31:39)

  2. Volume Updates (vipul, 22:32:33)
    1. vipul still working on re-enabling volume support (vipul, 22:32:49)

  3. CI Updates / Image updates (vipul, 22:34:11)
    1. using the tripleo disk image builder, plan is to replace ubuntu-vm-builder (vipul, 22:37:01)
    2. image buildling work still in progress (vipul, 22:37:59)
    3. Redstack integration into Devstack ongoing (vipul, 22:39:33)
    4. Tempest integration not started, conversations have begun (vipul, 22:40:01)

  4. os_amin / root user (vipul, 22:41:54)
    1. SlickNik steveleon grapex to figure this out (vipul, 22:42:25)
    2. possibly stick to os_admin as admin mysql user, until we have a use case (vipul, 22:43:28)

  5. Dealing with Redstack (vipul, 22:43:58)
    1. we're dealing with it (vipul, 22:46:08)

  6. feature discussion (vipul, 22:48:24)
    1. no user-level quotas, feature #1 add user-level quotas and update management APIs (vipul, 22:49:45)
    2. https://github.com/klmitch/turnstile (hub_cap, 22:50:16)
    3. https://github.com/klmitch/turnstile (hub_cap, 22:50:21)
    4. look at Turnstyle, repose as possible integration points (vipul, 22:51:22)
    5. ACTION: chat up w/ the openstack people about whether all projects should maintain their own quotas (hub_cap, 22:51:25)
    6. replication is also part of our roadmap (vipul, 22:54:49)
    7. ACTION: vipul and hub_cap to set up formal roadmap/feature meeting (vipul, 22:58:16)
    8. https://github.com/rackspace/Tempo (vipul, 23:04:15)

  7. Open Discussion (vipul, 23:06:24)
    1. prereq for migrations - grouping of instances (hub_cap, 23:06:44)
    2. consider tagging instances (vipul, 23:08:16)
    3. 12.04 support completed (vipul, 23:09:59)


Meeting ended at 23:14:03 UTC (full logs).

Action items

  1. dkehn to discuss offline about keystone users required by Redstack
  2. vipul to file bug to convert image building to tripleo image builder
  3. vipul to discuss percona baked into image with hub_cap
  4. SlickNik and steveleon to look into default guest user
  5. esp1 grapex to continue working on fixing all real-mode tests
  6. hub_cap to work on moving the extensions for mgmt api to public
  7. hub_cap to provide another update on OVZ
  8. chat up w/ the openstack people about whether all projects should maintain their own quotas
  9. vipul and hub_cap to set up formal roadmap/feature meeting


Action items, by person

  1. dkehn
    1. dkehn to discuss offline about keystone users required by Redstack
  2. esp1
    1. esp1 grapex to continue working on fixing all real-mode tests
  3. grapex
    1. esp1 grapex to continue working on fixing all real-mode tests
  4. hub_cap
    1. vipul to discuss percona baked into image with hub_cap
    2. hub_cap to work on moving the extensions for mgmt api to public
    3. hub_cap to provide another update on OVZ
    4. vipul and hub_cap to set up formal roadmap/feature meeting
  5. openstack
    1. chat up w/ the openstack people about whether all projects should maintain their own quotas
  6. SlickNik
    1. SlickNik and steveleon to look into default guest user
  7. steveleon
    1. SlickNik and steveleon to look into default guest user
  8. vipul
    1. vipul to file bug to convert image building to tripleo image builder
    2. vipul to discuss percona baked into image with hub_cap
    3. vipul and hub_cap to set up formal roadmap/feature meeting


People present (lines said)

  1. hub_cap (205)
  2. vipul (137)
  3. SlickNik (56)
  4. cp16net (35)
  5. dkehn (19)
  6. esp1 (15)
  7. juice_ (11)
  8. steveleon (10)
  9. grapex (9)
  10. datsun180b (4)
  11. openstack (3)
  12. yidclare (1)


Generated by MeetBot 0.1.4.