#openstack-tc: tc

Meeting started by JayF at 18:00:57 UTC (full logs).

Meeting summary

  1. Roll Call (JayF, 18:01:01)
    1. Today's meeting is being held primarily via video call. Action items and meeting minutes will be documented in IRC but for a full replay of the meeting, please visit the OpenStack TC youtube channel, where the recording will be uploaded soon. (JayF, 18:01:21)
    2. https://www.youtube.com/channel/UCBuGwBXOmWHydSE09RM84wQ (JayF, 18:01:23)

  2. Follow up on tracked action items (JayF, 18:04:33)
    1. https://etherpad.opendev.org/p/JayF-Nov-2023-MeetPad-v-Zoom (JayF, 18:04:50)
    2. Jay is not taking further action on moving TC meetings from Zoom. Encourages other tc-members who may have strong feelings about Zoom-located meetings to write up a proposal to change if they wish a change to happen. (JayF, 18:18:20)

  3. Gate Health Check (JayF, 18:18:28)
    1. Dan reports nothing serious; a single flakey test with Nova that is likely nova's fault. Tokens caching client patch merged; numbers have improved but some reports that other behaviors may be worse. Overall health is OK but slowly regressing. (JayF, 18:20:31)
    2. https://bugs.launchpad.net/oslo.utils/+bug/2042886 versionutils convert_version_to_tuple fails with beta versions (linked in zoom chat by slaweq) (fungi, 18:21:45)
    3. PBR 6.0.0 released just now (adding PEP 660 support, dropping Sphinx integration), keep an eye out for problems: https://review.opendev.org/c/openstack/releases/+/900041 (fungi, 18:24:10)

  4. Leaderless Projects (JayF, 18:27:41)
    1. https://etherpad.opendev.org/p/2024.1-leaderless (JayF, 18:29:01)
    2. tc-members are encouraged to review the etherpad and review PTL appointments (JayF, 18:30:22)

  5. Implementation of Unmaintained Branch Statuses (JayF, 18:30:39)
    1. https://etherpad.opendev.org/p/early-caracal-unmaintained-transition (JayF, 18:30:50)
    2. https://review.opendev.org/c/openstack/project-team-guide/+/897505 (JayF, 18:31:20)
    3. TC discussed logistics of implementing unmaintained status; main item we need is to ensure we engage releases team to make sure whatever path we pick for implementation works well for them. We need to ensure those communications explicitly include the fact that UM->EOL transitions may become the only release transition that does not require a PTL approval. (JayF, 18:48:32)
    4. Resolution on unmaintained branches: https://governance.openstack.org/tc/resolutions/20230724-unmaintained-branches.html (fungi, 18:54:09)

  6. PTG Follow Ups (JayF, 18:54:47)
    1. Jay will send email to the ML in the next week summarizing TC PTG activities and transition tracked items to 2024.1 TC Tracker (JayF, 18:55:21)

  7. Open Discussion and Review (JayF, 18:55:27)
    1. This month's OpenInfra Foundation newsletter is being finalized tomorrow, if you have any content you want included for OpenStack please add it to https://etherpad.opendev.org/p/newsletter-openstack-news today and I'll try to include it. (fungi, 18:55:27)
    2. https://review.opendev.org/q/status:open+repo:openstack/governance (JayF, 18:55:52)
    3. OpenInfra Live is hosting a PTG recap episode for anyone wishing to participate: https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/P4Y66SJNBG4DGW7URYAAJGKAI7NA33F5/ (fungi, 18:56:02)
    4. ACTION: Jay to sign up to rep TC at the PTG OpenInfra Live recap (JayF, 18:58:20)
    5. Recording to be uploaded to youtube later today. (JayF, 19:00:34)


Meeting ended at 19:00:36 UTC (full logs).

Action items

  1. Jay to sign up to rep TC at the PTG OpenInfra Live recap


People present (lines said)

  1. JayF (31)
  2. fungi (7)
  3. gmann (6)
  4. opendevmeet (4)
  5. bauzas (4)
  6. rosmaita (2)
  7. knikolla (1)
  8. dansmith (1)
  9. clarkb (1)


Generated by MeetBot 0.1.4.