#openstack-meeting-4: watcher

Meeting started by acabot at 09:00:05 UTC (full logs).

Meeting summary

  1. Announcements (acabot, 09:01:14)
    1. we will submit Watcher to the big tent today, its still time to review the commit msg https://etherpad.openstack.org/p/watcher-big-tent-commit-msg (acabot, 09:02:01)
    2. Watcher puppet repository creation currently in still in review (acabot, 09:02:24)
    3. sballe started a scope benchmark between Congress/Watcher/Craton, feel free to complete slides https://docs.google.com/presentation/d/1B_Wa_xSqj-Ovf_qTMdpFt7NrwobB2UhHcmwCTApk2OY/edit?usp=sharing (acabot, 09:03:17)
    4. next mid-cycle will be announced next week on the ML and we will have only 10 seats so if you plan to join, please register asap on https://www.eventbrite.com/e/watcher-newton-mid-cycle-developer-meetup-tickets-25267323244 (acabot, 09:04:20)
    5. gzhai2 & sballe also started a discussion about infra requirements to test Watcher at the end of the Newton cycle, discussions are in an etherpad https://etherpad.openstack.org/p/watcher-test-environment-specifications (acabot, 09:05:37)
    6. a discussion has been started on the ML regarding Nova deprecated APIs that are needed by Watcher http://lists.openstack.org/pipermail/openstack-dev/2016-May/095726.html (acabot, 09:07:03)
    7. ACTION: gzhai2 complete required hardware specs in https://etherpad.openstack.org/p/watcher-test-environment-specifications (acabot, 09:07:34)

  2. Review Action Items (acabot, 09:08:30)
    1. Specs for plugins-parameters & Airflow event based migration strategy spec have been merged (acabot, 09:08:59)
    2. ACTION: gzhai2 assign the BP https://blueprints.launchpad.net/watcher/+spec/uniform-airflow-migration-strategy to you (acabot, 09:10:42)
    3. ACTION: gzhai2 rebase https://review.openstack.org/#/c/297556/ (acabot, 09:12:10)
    4. Audit parameters should be persistent in Db needs review from core (acabot, 09:12:32)
    5. ACTION: acabot jwcroppe sballe_ review https://review.openstack.org/#/c/317130/ (acabot, 09:12:42)
    6. ACTION: jed56 review https://review.openstack.org/#/c/315551/ (acabot, 09:13:54)
    7. ACTION: acabot review https://review.openstack.org/#/c/315551/ (acabot, 09:14:03)
    8. Cluster model objects wrapper work items are still missing (acabot, 09:14:18)
    9. ACTION: tpeoples complete work items on https://review.openstack.org/#/c/287019/ or free this BP for our next meeting (acabot, 09:14:56)
    10. Add Overload standard deviation strategy needs a new PS (acabot, 09:15:22)
    11. ACTION: alexchadin add a new PS on https://review.openstack.org/#/c/297590/ (acabot, 09:15:38)
    12. Workload balance migration strategy implementation needs a new PS (acabot, 09:15:53)
    13. ACTION: gzhai2 junjie add a new PS to https://review.openstack.org/#/c/292188/ (we will merge it by EOW) (acabot, 09:19:21)
    14. more reviewers are needed to complete plugins parameters https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/plugins-parameters (acabot, 09:19:58)
    15. ACTION: alexchadin review https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/plugins-parameters (acabot, 09:22:06)
    16. most of the openstackclient-plugin has been merged https://review.openstack.org/#/q/status:open+project:openstack/python-watcherclient+branch:master+topic:bp/openstackclient-plugin (acabot, 09:22:50)
    17. ACTION: dtardivel merge openstackclient-plugin related doc updates asap (acabot, 09:24:07)
    18. https://www.irccloud.com/pastebin/5x3ZfH1I/ (dtardivel, 09:24:26)
    19. ACTION: gzhai2 rebase https://review.openstack.org/#/c/297557/ (acabot, 09:24:34)

  3. Blueprint/Bug Review and Discussion (acabot, 09:25:22)
    1. Newton-1 is due to May 30th https://launchpad.net/watcher/+milestone/newton-1 (acabot, 09:25:48)
    2. ACTION: acabot postpone https://blueprints.launchpad.net/watcher/+spec/efficacy-indicator to Newton-2 (acabot, 09:29:57)
    3. ACTION: ghzai2 alexchadin junjie jinquan we will merge your code by next monday so please be ready to review and patch your code (acabot, 09:33:11)

  4. Open Discussion (acabot, 09:34:05)
    1. ACTION: acabot jed56 sign up for the mid-cycle (acabot, 09:35:04)
    2. ACTION: acabot submit a request to OSIC to get a test cluster (acabot, 09:48:48)


Meeting ended at 09:53:27 UTC (full logs).

Action items

  1. gzhai2 complete required hardware specs in https://etherpad.openstack.org/p/watcher-test-environment-specifications
  2. gzhai2 assign the BP https://blueprints.launchpad.net/watcher/+spec/uniform-airflow-migration-strategy to you
  3. gzhai2 rebase https://review.openstack.org/#/c/297556/
  4. acabot jwcroppe sballe_ review https://review.openstack.org/#/c/317130/
  5. jed56 review https://review.openstack.org/#/c/315551/
  6. acabot review https://review.openstack.org/#/c/315551/
  7. tpeoples complete work items on https://review.openstack.org/#/c/287019/ or free this BP for our next meeting
  8. alexchadin add a new PS on https://review.openstack.org/#/c/297590/
  9. gzhai2 junjie add a new PS to https://review.openstack.org/#/c/292188/ (we will merge it by EOW)
  10. alexchadin review https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/plugins-parameters
  11. dtardivel merge openstackclient-plugin related doc updates asap
  12. gzhai2 rebase https://review.openstack.org/#/c/297557/
  13. acabot postpone https://blueprints.launchpad.net/watcher/+spec/efficacy-indicator to Newton-2
  14. ghzai2 alexchadin junjie jinquan we will merge your code by next monday so please be ready to review and patch your code
  15. acabot jed56 sign up for the mid-cycle
  16. acabot submit a request to OSIC to get a test cluster


Action items, by person

  1. acabot
    1. acabot jwcroppe sballe_ review https://review.openstack.org/#/c/317130/
    2. acabot review https://review.openstack.org/#/c/315551/
    3. acabot postpone https://blueprints.launchpad.net/watcher/+spec/efficacy-indicator to Newton-2
    4. acabot jed56 sign up for the mid-cycle
    5. acabot submit a request to OSIC to get a test cluster
  2. alexchadin
    1. alexchadin add a new PS on https://review.openstack.org/#/c/297590/
    2. alexchadin review https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/plugins-parameters
    3. ghzai2 alexchadin junjie jinquan we will merge your code by next monday so please be ready to review and patch your code
  3. dtardivel
    1. dtardivel merge openstackclient-plugin related doc updates asap
  4. gzhai2
    1. gzhai2 complete required hardware specs in https://etherpad.openstack.org/p/watcher-test-environment-specifications
    2. gzhai2 assign the BP https://blueprints.launchpad.net/watcher/+spec/uniform-airflow-migration-strategy to you
    3. gzhai2 rebase https://review.openstack.org/#/c/297556/
    4. gzhai2 junjie add a new PS to https://review.openstack.org/#/c/292188/ (we will merge it by EOW)
    5. gzhai2 rebase https://review.openstack.org/#/c/297557/
  5. jed56
    1. jed56 review https://review.openstack.org/#/c/315551/
    2. acabot jed56 sign up for the mid-cycle
  6. jinquan
    1. ghzai2 alexchadin junjie jinquan we will merge your code by next monday so please be ready to review and patch your code
  7. openstack
    1. gzhai2 complete required hardware specs in https://etherpad.openstack.org/p/watcher-test-environment-specifications
    2. gzhai2 rebase https://review.openstack.org/#/c/297556/
    3. acabot jwcroppe sballe_ review https://review.openstack.org/#/c/317130/
    4. jed56 review https://review.openstack.org/#/c/315551/
    5. acabot review https://review.openstack.org/#/c/315551/
    6. tpeoples complete work items on https://review.openstack.org/#/c/287019/ or free this BP for our next meeting
    7. alexchadin add a new PS on https://review.openstack.org/#/c/297590/
    8. gzhai2 junjie add a new PS to https://review.openstack.org/#/c/292188/ (we will merge it by EOW)
    9. alexchadin review https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/plugins-parameters
    10. gzhai2 rebase https://review.openstack.org/#/c/297557/
  8. sballe_
    1. acabot jwcroppe sballe_ review https://review.openstack.org/#/c/317130/


People present (lines said)

  1. acabot (94)
  2. gzhai2 (29)
  3. sballe_ (22)
  4. alexchadin (19)
  5. vincentfrancoise (9)
  6. jed56 (5)
  7. dtardivel (5)
  8. jinquan (3)
  9. eil397 (3)
  10. openstack (3)
  11. vtech (2)


Generated by MeetBot 0.1.4.