#edge-computing-group: weekly_edge_computing_group_call

Meeting started by csatari at 13:04:06 UTC (full logs).

Meeting summary

  1. Roll call (csatari, 13:04:19)
    1. Gergely Csatari (csatari, 13:04:28)

  2. Links (csatari, 13:07:20)
    1. https://etherpad.openstack.org/p/YVR-edge-keystone-brainstorming (csatari, 13:07:33)
    2. https://wiki.openstack.org/wiki/Edge_Computing_Group#Keystone (csatari, 13:07:43)

  3. Usage of Keystone federation on the field (csatari, 13:09:54)
    1. StarlingX does not use Keystone federation at the moment. (csatari, 13:10:17)
    2. Loss of connectivity between the client and the IdP can result in problems in case of Keystone federation. (csatari, 13:10:50)
    3. StarlingX uses synchronisation of data. Now it moves towards a database synchronisation approach. Database synchronisation is half done. (csatari, 13:13:16)
    4. The db replicaiton is done via an agent which is able to do schema transformation in case of diferent versions. (csatari, 13:15:17)
    5. The problem with API synchronisatio: 1) there is a table with revocation events which is populated by different actions, like password change 2) User ID-s and project ID-s are not synchronised (this is needed to enable the usage of Fernet keys generated remotely). (csatari, 13:20:36)
    6. There is an activity to implement Galera spanning over multiple locations. (csatari, 13:21:12)
    7. Galera is able to synch ~16 db-s. (csatari, 13:23:37)
    8. ACTION: csatari To do some analyzis on the listed concerns for the alternatives. (csatari, 13:31:42)
    9. Mapping rules for Keystone federation can be static. (csatari, 13:32:34)
    10. Singned SAML-s can be user only once and only for a specific SP. (csatari, 13:36:59)
    11. Unscoped token can be reused, but can expire. (csatari, 13:37:34)
    12. ACTION: Greg to get the StarlingX database replication design document to the Edge Computing Group wiki (csatari, 13:44:15)
    13. ACTION: csatari Update the wiki to have the two DB synch alternatives represented. (csatari, 13:46:49)

  4. Federation testing (csatari, 13:47:55)
  5. Closing (csatari, 13:56:38)
    1. More meetings to come week after next week. (csatari, 13:57:28)
    2. We will have a session in the PTG about Keystone. (csatari, 13:57:39)
    3. We will use the same timeslot. (csatari, 13:58:06)
    4. Thursday 15h-16h CET. (csatari, 13:58:18)


Meeting ended at 13:59:28 UTC (full logs).

Action items

  1. csatari To do some analyzis on the listed concerns for the alternatives.
  2. Greg to get the StarlingX database replication design document to the Edge Computing Group wiki
  3. csatari Update the wiki to have the two DB synch alternatives represented.


Action items, by person

  1. csatari
    1. csatari To do some analyzis on the listed concerns for the alternatives.
    2. csatari Update the wiki to have the two DB synch alternatives represented.


People present (lines said)

  1. csatari (31)
  2. openstack (3)
  3. bogdando (3)
  4. mbeierl (2)


Generated by MeetBot 0.1.4.