#openstack-keystone: keystone

Meeting started by d34dh0r53 at 15:12:02 UTC (full logs).

Meeting summary

    1. https://openinfra.dev/legal/code-of-conduct (d34dh0r53, 15:13:54)

  1. roll call (d34dh0r53, 15:14:01)
  2. review past meeting work items (d34dh0r53, 15:15:14)
    1. https://meetings.opendev.org/meetings/keystone/2025/keystone.2025-06-04-15.05.html (d34dh0r53, 15:15:28)
    2. ACTION: dmendiza update S-RBAC topic in meeting etherpad (d34dh0r53, 15:17:10)

  3. liaison updates (d34dh0r53, 15:17:19)
  4. specification OAuth 2.0 (hiromu) (d34dh0r53, 15:18:14)
    1. https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext (d34dh0r53, 15:18:16)
    2. https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability (d34dh0r53, 15:18:18)
    3. https://review.opendev.org/c/openstack/keystone-specs/+/861554 (merged) (d34dh0r53, 15:18:24)
    4. https://review.opendev.org/q/topic:bp%252Fsupport-oauth2-mtls (merged) (d34dh0r53, 15:18:28)
    5. https://review.opendev.org/c/openstack/keystone/+/838108 (merged) (d34dh0r53, 15:18:34)
    6. https://review.opendev.org/c/openstack/keystoneauth/+/838104 (merged) (d34dh0r53, 15:18:37)

  5. specification Secure RBAC (dmendiza) (d34dh0r53, 15:20:15)
    1. https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_ (d34dh0r53, 15:20:17)

  6. specification OpenAPI support (gtema) (d34dh0r53, 15:20:59)
    1. https://review.opendev.org/q/topic:%22openapi%22+project:openstack/keystone (d34dh0r53, 15:21:02)

  7. open discussion (d34dh0r53, 15:22:36)
    1. https://summit2025.openinfra.org/cfp/ (d34dh0r53, 15:23:59)

  8. bug review (d34dh0r53, 15:30:34)
    1. https://bugs.launchpad.net/keystone/?orderby=-id&start=0 (d34dh0r53, 15:30:37)
    2. https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0 (d34dh0r53, 15:30:53)
    3. https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0 (d34dh0r53, 15:31:39)
    4. https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0 (d34dh0r53, 15:32:02)
    5. https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0 (d34dh0r53, 15:32:15)
    6. https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0 (d34dh0r53, 15:32:34)

  9. conclusion (d34dh0r53, 15:32:44)


Meeting ended at 15:34:17 UTC (full logs).

Action items

  1. dmendiza update S-RBAC topic in meeting etherpad


People present (lines said)

  1. d34dh0r53 (67)
  2. gtema (14)
  3. opendevmeet (3)
  4. dmendiza[m] (3)
  5. xek (2)


Generated by MeetBot 0.1.4.